CIS-3210 Lab #8: VLANs and Trunking

Reading: Finish me!

In this lab, you will configure a couple of VLANs and define a trunk line between two switches that carry those VLANs.

Part 1: Configure The Network

Using Packet Tracer, construct the following network:

Lab #8 Network

Device Interface IP Address Subnet Mask Default Gateway
S1 VLAN1 192.168.1.11 255.255.255.0 N/A
S2 VLAN1 192.168.1.12 255.255.255.0 N/A
PC-A FE0 192.168.10.3 255.255.255.0 192.168.10.1
PC-B FE0 192.168.10.4 255.255.255.0 192.168.10.1
PC-C FE0 192.168.20.3 255.255.255.0 192.168.20.1
Addressing Table

As with the previous lab, use 2960-24TT switches. As usual, be careful to connect each line to the indicated interface. In this lab, it will matter because the VLANs need to be configured on specific interfaces.

As usual, configure the basic settings (Global Settings and Console Access; you do not need to configure remote access for this lab) on all the devices. Configure the network interfaces using the addresses shown in the addressing table.

Can the PCs ping either of the switches? Can the switches ping each other? Can the PCs ping each other? Explain your observations.

Note that for this lab, the default gateway settings on the PCs don't really matter because there are no routers involved anyway. This is a purely switched network.

Part 2: Create VLANs and Assign Switchports

Create the following VLANs on both switches. The commands for S1 are as follows:

  S1(config)# vlan 10
  S1(config-vlan)# name Student
  S1(config-vlan)# vlan 20
  S1(config-vlan)# name Faculty
  S1(config-vlan)# vlan 99
  S1(config-vlan)# name Management
  S1(config-vlan)# exit

Use the show vlan command to verify your work.

On S1 adjust the VLAN associated with the port connecting to PC-A, adjust the VLAN associated with the port connecting to S2, and move the IP address for the SVI over to VLAN99 as follows:

  S1(config)# interface FastEthernet0/6
  S1(config-if)# switchport mode access
  S1(config-if)# switchport access vlan 10
  S1(config-if)# interface FastEthernet0/1
  S1(config-if)# switchport mode access
  S1(config-if)# switchport access vlan 10
  S1(config-if)# exit

  S1(config)# interface vlan 1
  S1(config-if)# no ip address
  S1(config-if)# interface vlan 99
  S1(config-if)# ip address 192.168.1.11 255.255.255.0
  S1(config-if)# exit

The first set of commands associates the appropriate switch ports with VLAN 10. The second set of commands changes the SVI to be connected to the management VLAN. Verify that these changes were made correctly, and then make corresponding changes to S2.

Verify that the Student PCs can now ping each other. Why does it work? Are the switches able to ping each other? Explain.

Part 3: Create a Trunk

Configure the connection between S1 and S2 to be a trunk. The commands for S1 are as follows:

  S1(config)# interface FastEthernet0/1
  S1(config-if)# switchport mode trunk
  S1(config-if)# switchport trunk allowed vlan 10,20,99
  S1(config-if)# exit

Make a corresponding change to S2. Verify that your trunks are configured using the command show interfaces trunk. Are the PCs able to ping each other? Are the switches able to ping each other? Which systems can the faculty PC ping? Explain your observations.

Submission

For this lab, submit your final PacketTracer model, along with a document containing the commands you used to configure your devices, and your answers to the questions. The preferred document format is PDF, but Word, ODT, or plain text is also acceptable.


Last Revised: 2023-12-20
© Copyright 2023 by Peter Chapin <peter.chapin@vermontstate.edu>